Site Loader
スタッフブログ

iOSアプリを申請する際にバリデーションしますが、そのとき以下のメッセージが表示されるようになりました。

This bundle is invalid. The key UIRequiredDeviceCapabilities in Info.plist may not contain values that would prevent this application from running on devices that were supported by previous version.

こんなエラーメッセージが出るようになった。

これは、古いバージョン対応させるなら、armv7が現在だと指定されていて、armv6を追加しろとメッセージがでていたのが、そもそも「UIRequiredDeviceCapabilities」こいついらないんじゃねぇ?ということのようです。

plistから、

Key:UIRequiredDeviceCapabilities

およびその値がArrayで指定してあるので、ごっそりと削除。

無事エラーでなくなりました。、

Post Author: Futoshi

代表取締役 兼 エンジニア の岡崎 太です。よろしくです。

コメントを残す

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください